Loading...

Communications and Remote Installation Requirements

During backups, application-aware backups run a remote installation workflow to push application plug-ins to guest VMs or instances that are running the applications that will be backed up. The CommServe host, MediaAgent, and VSA proxy must be able to communicate with the virtual machines that run applications.

Application-aware backups install the following components into the guest VMs that are being backed up, if the components are not already present:

  • File System Core package (to ensure that other components can be installed remotely)
  • MediaAgent (includes binaries that are used by application-aware backups, but does not enable MediaAgent role on the guest VM)
  • Application plug-in (to enable backup of application data)

Notes:

  • Guest VMs running Windows 2003 do not support .NET 4.5. Commvault packages on those guest VMs will remain on Service Pack 6 and will not be upgraded to Service Pack 7 or a more recent service pack, unless you upgrade the guest operating system to Windows 2008 or a more recent Windows version.
  • When you restore an application from an application-aware backup job and the destination VM for the application does not have the Virtual Server Agent installed, the restore job initiates a remote installation of the VSA and .NET 4.5.
  • To enable discovery of applications running on Windows VMs when using a Linux proxy, install the File System Core package on the guest VMs before running an application-aware backup.

Related Topics

Last modified: 12/18/2018 9:48:23 PM