Loading...

PostgreSQL Agent: System Requirements

The following requirements are for the PostgreSQL Agent:

PostgreSQL and Enterprise DB Version 9.2 (or later)

Operating System

Operating System Version

Architecture

AIX

AIX 7.1 64-bit

x64 or compatible processors

FreeBSD

FreeBSD 10.x

x64 or compatible processors

 

FreeBSD 9.x

*Supported for PostgreSQL Version 9.2 only

x64 or compatible processors

Linux

Debian

 

 

Debian 9.x

x64 or compatible processors

 

Debian 8.x

x64 or compatible processors

 

Debian 7.x

x64 or compatible processors

 

Debian 6.x

x64 or compatible processors

 

Debian 5.x

x64 or compatible processors

 

Red Hat Enterprise Linux/CentOS

 

 

Red Hat Enterprise Linux/Oracle Linux Enterprise/CentOS 7.x

x64, Power PC (Little endian) or compatible processors

 

Red Hat Enterprise Linux/Oracle Linux Enterprise/CentOS 6.x with glibc 2.12.x

Intel Pentium, x64, Power PC (Little endian) or compatible processors

 

Red Hat Enterprise Linux/Oracle Linux Enterprise/CentOS 5.x with glibc 2.5.x

Intel Pentium, x64 or compatible processors

 

Source Mage Linux

 

 

Source Mage Linux

x64

 

SuSE Linux (SLES)

 

 

SuSE Linux 12.0

x64, Power PC (Little endian) or compatible processors

 

SuSE Linux 11.x with glibc 2.9.x and later

Intel Pentium, x64, Power PC (Little endian) or compatible processors

 

Ubuntu

 

 

Ubuntu 18.04 LTS

Intel Pentium, x64 or compatible processors

 

Ubuntu 16.04 LTS

Intel Pentium, x64 or compatible processors

 

Ubuntu 14.04 LTS

Intel Pentium, x64 or compatible processors

 

Ubuntu 12.04 LTS

Intel Pentium, x64 or compatible processors

Solaris

Solaris 11.x

x64, Sparc T/M series

 

Solaris 10 Update 6 or equivalent

x64, Sparc T/M series

Windows

Windows 2016

 

 

Microsoft Windows Server 2016 Editions

All Windows-compatible processors supported

 

Windows 2012

 

 

Microsoft Windows Server 2012 R2 Editions

All Windows-compatible processors supported

 

Microsoft Windows Server 2012 Editions*

*Core Editions are not supported.

*Install 32 bit version of the software if you have 32 bit PostgreSQL server on Windows 2008 x64 edition.

 

 

Windows 2008

 

 

Microsoft Windows Server 2008 R2 Editions

*Core Editions are not supported.

All Windows-compatible processors supported

 

Microsoft Windows Server 2008 Editions

Core Editions are not supported.

*Install 32 bit version of the software if you have 32 bit PostgreSQL server on Windows 2008 x64 edition.

All Windows-compatible processors supported

Hard Drive

1 GB minimum of hard disk space for installing the software.

256 MB of free disk space is required for job result directory.

256 MB of free disk space is required for log directory.

Notes on Block-Level Backups

  • Block-level backups are supported only on Linux platforms.

    For supported Linux kernel version details of PostgreSQL block-level backups, see List of Supported Kernel Versions.

  • Network File System (NFS) is not supported for PostgreSQL block-level backups.

Miscellaneous

The File System Agent will be automatically installed during installation of this software, if it is not already installed. For System Requirements and install information specific to the File System Agents, refer to System Requirements - Linux File System iDataAgent.

Microsoft Visual C++

The following Redistributable Package is installed automatically. Note that the Redistributable Package can co-exist with other versions of this software.

Microsoft Visual C++ 2010 Redistributable Package

DISCLAIMER

Third-party maintenance (minor) releases or service packs that are supported by the Commvault software may not be listed in our System Requirements. When possible, Commvault provides information on any known issues related to these minor releases or service packs. In some cases, these minor releases or service packs affect how the Commvault software works. Commvault software may experience changes in functionality as the result of the third-party minor release or service pack. These changes are beyond the control of Commvault. Platforms that are supported in the current version of Commvault software may not be supported in earlier versions of the software. Contact your software provider to ensure that third-party minor releases or service packs are compatible with the Commvault software.

Additional considerations regarding minimum requirements and End-of-Life policies from third-party vendors also apply.

Last modified: 11/21/2018 11:42:43 AM