Loading...

Search and Analytics: System and Hardware Requirements

Applies to: Index Store package and Content Analyzer package

This section contains system and hardware requirements for deploying search and analytics solutions on a server according to the type of data that you want to use.

Use the latest version of the operating system software listed in the Operating System table. Commvault software fully supports the latest version of an operating system until the vendor ends support. Newer versions of Commvault software might not install on operating systems for which vendor support has ended. For information about the Microsoft support lifecycle, go to the Microsoft Support website, Microsoft Support Lifecycle. For support lifecycle information for other operating systems, contact the appropriate software vendor.

Operating System

Operating System Version

Windows

Windows Server 2019

 

Microsoft Windows Server 2019 Editions

*The Content Analyzer package is not supported on Windows Server 2019.

 

Windows Server 2016

 

Microsoft Windows Server 2016 Editions

*Nano Servers are not supported. See Considerations for Microsoft Windows Server 2016 for more information.

 

Windows Server 2012

 

Microsoft Windows Server 2012 Editions

 

Microsoft Windows Server 2012 R2 Editions*

*Core Editions are not supported.

Linux

Applies to: Content Analyzer package

Red Hat Enterprise Linux/CentOS

If the Index Server will be configured with the NFS Index role to support NFS ObjectStore, you can install the Index Store package and the Index Gateway package on versions of the Red Hat operating system.

Operating System

Operating System Version

Linux

Red Hat Enterprise Linux/CentOS

 

Red Hat Enterprise Linux/CentOS 7.3 with glibc 2.17.x

 

Red Hat Enterprise Linux/CentOS 7.4 with glibc 2.17.x

 

Red Hat Enterprise Linux/CentOS 7.5 with glibc 2.17.x

Related Topics

For information about sizing requirements, see the following:

Last modified: 8/26/2019 8:22:00 PM