V11 Service Pack 9
Loading...

System Requirements - CommServe Server

The following requirements are for the CommServe server.

Best Practice

Use the latest version of the operating system software listed in the Operating System table. Commvault software fully supports the latest version of an operating system until the Microsoft Extended Support End Date. Newer versions of Commvault software might not install on operating systems for which Microsoft support has ended. For information about the Microsoft support lifecycle, go to the Microsoft Support website, Microsoft Support Lifecycle.

Operating System

Windows

Microsoft Windows Server 2016 Editions

See Considerations for Microsoft Windows Server 2016 for more information.

Microsoft Windows Server 2012 Editions

See Considerations for Microsoft Windows Server 2012, 2012 R2, and Windows 8.x for more information.

Microsoft Windows Server 2012 R2 Editions

See Considerations for Microsoft Windows Server 2012, 2012 R2, and Windows 8.x for more information.

Cluster - Support

The software can be installed on a Cluster if clustering is supported by the above-mentioned operating systems.

For information on supported cluster types, see Clustering - Support.

Processor

All Windows-compatible processors supported

Hardware Specifications

The hardware requirements for CommServe installed on either physical or virtual machines is explained in Hardware Specifications for CommServe.

Notes:

  • The software installation requires 10 GB of disk space on the operating system drive. This space is used for temporary files copied during the installation or upgrade of the CommServe and Microsoft SQL Server software.
  • For hard drive requirements details of other components (such as the MediaAgent), see the corresponding system requirements pages.

Database Engine

The Microsoft SQL Server application that is installed on the computer must be dedicated to support the software and cannot be shared by other applications.

Microsoft SQL Server 2014 Standard Edition

Microsoft SQL Server 2014 Standard Edition is automatically installed during the installation of the CommServe software. Later SQL Server service packs and updates must be installed manually. You must update the SQL Server with any important updates released by Microsoft. For more information on scalability (such as CPU, socket, and memory limits), performance, and other features supported by the standard edition, refer to the Microsoft documentation.

If you set up the CommServe in a virtual environment and use Microsoft SQL Server 2014, set the socket count to four and the core count to four.

Microsoft SQL Server 2012 Enterprise Edition

Microsoft SQL Server 2012 Enterprise Edition with Service Pack 2 (SP2) and Cumulative Update 4 (CU4) is also supported. If you plan to use SQL Server 2012, review important recommendations listed in Considerations for SQL Server 2012.

Recommended SQL Server Settings

The database instance used by the software requires specific SQL server settings. Using the SQL Management Studio, verify the SQL properties listed below.

SQL Memory Size

Access the server properties and navigate to the Memory page. The maximum server memory should be 50% of the physical memory available in the computer on which the software is installed.

Server Collation

Run the sp_helpsort system stored procedure, and verify that the server default collation has the following properties:
  • Character Set is 1252/ISO (default)
  • Sort Order is Dictionary order, and case is Insensitive
  • Unicode Collation includes General Unicode, case Insensitive, width Insensitive

Temp Database Properties

Navigate to the tempdb database (under the Databases | System Databases node), and access its properties to verify the following:
  • The tempdb database has at least 100 MB of disk space. Depending on the components that you decide to install later, additional space may needed.
  • Click the Files page to check the autogrowth properties of the database files. The Enable Autogrowth option must be selected, and the file growth should be set to 10%.
Note: To preallocate tempdb space or disable the autogrowth option in an Enterprise environment, allocate atleast 30GB space for tempdb. Monitor and track the usage of tempdb periodically to ensure that the tempdb usage is less than 20GB. If the tempdb size is nearing 20GB, contact the software vendor to investigate the reason for tempdb growth.

Service Accounts

For Service Accounts, use the same Local System account for each service and enable auto-start for SQL services.

On clustered environments, use an account with administrator privileges (such as, a member of the Administrator local group of the computer or domain).

Hardware Validation for CommServe Database

The CommServe database needs to be on a fast disk for optimal backup performance. Before setting up the CommServe, the storage volumes must be validated for high performance. This can be done using the IO meter tool which measures the IOPs (Input Output Operations per second). For more information on the IO meter tool, see IOPs for CommServe Database Volumes. For the CommServe IOPs requirements, see Hardware Specifications for CommServe.

Miscellaneous

Internet Explorer

Microsoft Internet Explorer (IE) version 8.0, 9.0, 10.0, and 11.0

.NET Framework Requirements

.NET Framework 3.5, 4.0, and 4.5 are required and are automatically installed.

Note: For .NET Framework 3.5, if the server is Windows 2012 or higher, the role is only enabled during installation if the machine has an internet connection. If there is no internet connection, you must manually enable the role.

IIS

By default, the Web Server and Web Console packages are installed with the CommServe. To install this software, IIS must be enabled on the CommServe computer and meet the following requirements:
  • Microsoft Internet Information Services (IIS) Manager version 10.0 (on Windows 2016 only)
  • Microsoft Internet Information Services (IIS) Manager version 8.0 or 8.5 (on Windows 2012 only)
  • Microsoft Internet Information Services (IIS) Manager version 7.0 (on Windows 2008 only)
  • Microsoft Internet Information Services (IIS) Manager version 7.5
  • All components of Microsoft Internet Information Services (IIS) Manager version 7.0 should be installed on Windows 2008

CommServe Name

By default, the Commvault software uses the name of the server computer (where the CommServe component is being installed) as the CommServe name. During the installation of the CommServe component, the software also allows you to specify a different CommServe name.

Note: The CommServe name cannot be "CommCell". If you change the CommServe name during installation, do not change it to "CommCell".

CommServe Database on CIFS

The CommServe's SQL database is not supported on a CIFS share.

Java Runtime Environment (JRE)

The software supports Java 8 Update 65 (JRE 1.8.0_65) or later versions.

If a supported version of Java is not installed on the computer, you will be prompted to install Java 8 update 121.

Notes on Combined Installations

Installing more than one Commvault package on a single computer is a common practice. For example, if the computer has an Exchange and an Oracle database, you will install the Exchange Database Agent and the Oracle Agent to protect the data from both databases.

When you combine multiple functions on a single computer, the storage resources required to support the software for that computer are not essentially cumulative. This is because Commvault packages share some of the same software. As a result, combined installations require about 30 MB less disk space than installations where the software resides on separate computers.

DISCLAIMER

Third-party maintenance (minor) releases or service packs that are supported by the Commvault software may not be listed in our System Requirements. When possible, Commvault provides information on any known issues related to these minor releases or service packs. In some cases, these minor releases or service packs affect how the Commvault software works. Commvault software may experience changes in functionality as the result of the third-party minor release or service pack. These changes are beyond the control of Commvault. Platforms that are supported in the current version of Commvault software may not be supported in earlier versions of the software. Contact your software provider to ensure that third-party minor releases or service packs are compatible with the Commvault software.

Additional considerations regarding minimum requirements and End-of-Life policies from third-party vendors also apply.