Loading...

Cassandra Agent System Requirements

The following requirements are for the Cassandra agent.

Cassandra 3.x/2.x

Operating System

Architecture

Linux

X64

If you do not use Cassandra with DataStax, then you need to modify the Commvault Cassandra properties file. For more information, see Modifying the Commvault Cassandra Properties File.

DataStax Configurations

The Commvault software supports the following DSE and Cassandra configurations. If you have a configuration that is not listed, then contact us at Dev-cassandra@commvault.com and we can assist you.

Cassandra 3.1. and Higher with DSE 5.1 and Higher

DSE version

Cassandra version

5.1.1

3.10.0.1695

5.1.4

3.11.0.1900

5.1.6

3.11.1.2070

5.1.7

3.11.1.2130

5.1.8

3.11.1.2261

5.1.9

3.11.1.2261

6.0.0

4.0.0.2349

Cassandra 3.0 with DSE 5.0.x

DSE version

Cassandra version

5.0.8

3.0.12.1656

5.0.3

3.0.9.1346

Cassandra 2.x with DSE 4.x

Note: Cassandra has deprecated 2.1.

DSE version

Cassandra version

4.8.2

2.11

4.8.3

2.11

4.8.11 to 4.8.13

2.17

4.8.14

2.1.19

Scylla 2.2

Operating System

Architecture

Linux

X64

Last modified: 6/25/2019 8:10:44 PM