Amazon S3 Cloud Library Creation Fails or Library Goes Offline with Access Denied Error

Symptom

Amazon S3 Cloud Library creation fails or library goes offline. The following error is displayed:

Failed to verify the device from MediaAgent [xxx] with the error [Failed to check cloud server status, error = [[Cloud] Access denied.

Cause

User or the IAM Role used during library creation may have the Effect: Deny for the DeleteObject action for all the resources.

Resolution

Add the following exception to opt out the deny effect for DeleteObject action for the dfaksdhfuq43yAF9834fmabvfjhFDGgv8743rvbfdabuyewbasdfahdDCCZfabdfbchasd object. (sample json file .)

{
    "Statement": [
        {
            "Effect": "Deny",
            "Action": [
            "s3:DeleteObject"
            ],
            "NotResource": [
            "arn:aws:s3:::###BucketName####/dfaksdhfuq43yAF9834fmabvfjhFDGgv8743rvbfdabuyewbasdfahdDCCZfabdfbchasd"
            ]
        }
    ]
}

For information on the other permissions required to setup Amazon S3 cloud library, see Amazon S3 - Access & Secret Access Keys.

Loading...