Private Metrics Reporting Server: System Requirements

Updated

Verify that your environment meets the system requirements for Private Reporting Servers.

Operating System

Important: Use the most recent version of the operating system that is listed. The Commvault software fully supports the most recent version of an operating system, until the vendor ends support. More recent versions of the Commvault software might not install on operating systems that are not supported by the vendor anymore. For information about the support lifecycle of an operating system, contact the vendor.

Windows

Operating system

Processor architecture

Microsoft Windows Server 2019 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2019 Core Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2016 Editions

Nano Servers are not supported. For more information, see Considerations for Microsoft Windows Server 2016.

All Windows-compatible processors are supported

Microsoft Windows Server 2012 Editions

Note: For new installations for Feature Release 11.24 and above, Microsoft Windows Server 2012 is not supported (new installations of Feature Release 11.24 and above use MS SQL Server 2019, which requires a minimum of MS Windows Server 2016).

All Windows-compatible processors are supported

Microsoft Windows Server 2012 R2 Editions

Server Core installations are not supported.

Note: For new installations for Feature Release 11.24 and above, Microsoft Windows Server 2012 is not supported (new installations of Feature Release 11.24 and above use MS SQL Server 2019, which requires a minimum of MS Windows Server 2016).

All Windows-compatible processors are supported

Linux

Operating system

Processor architecture

Red Hat Enterprise Linux/CentOS 7.7 with glibc 2.17.x

x64

Hard Drive

The hardware requirements for a Private Metrics Reporting Server installed on either physical or virtual machines are explained in Hardware Specifications for the Private Metrics Reporting Server.

Web Browser

The following web browsers are supported:

  • Apple Safari (versions that are not older than a year)

  • Google Chrome (versions that are not older than a year)

  • Mozilla Firefox (versions that are not older than a year)

  • Microsoft Edge

Software That Is Automatically Installed

Database Engine

Microsoft SQL Server 2019 Standard Edition is automatically installed during the installation of the Metrics Reporting Server software. If you have Microsoft SQL Server 2012 Enterprise Edition already installed in your environment, the Metrics Reporting Server will use the existing SQL Server.

For more information, see Database Engine under System Requirements - CommServe.

Internet Information Services

By default, the Web Server and Web Console packages are installed with the CommServe computer. To install this software, Microsoft Internet Information Services (IIS) must be enabled on the CommServe computer and must meet the following requirements:

  • Internet Information Services Manager version 10.0 (on Windows 2016 only)

  • Internet Information Services Manager version 8.0 or 8.5 (on Windows 2012 only)

  • Internet Information Services Manager version 7.5

.NET Framework

The Microsoft .NET Framework 4.6 is required and is automatically installed.

Tomcat Server

If the Apache Tomcat Server is not already installed, it is automatically installed with this software.

Note: You cannot manually upgrade the Apache Tomcat Server. The Commvault software always updates the Tomcat server with the most recent security updates, so that the components that use the Tomcat server do not have vulnerabilities that are reported by the open source community.

DISCLAIMER

Certain third-party software and service releases (together, "Releases") may not be supported by Commvault. You are solely responsible for ensuring Commvault’s products and services are compatible with any such Releases.