DB2 Agent Configuration Troubleshooting

Upgrade

DB20001: DB2 log archival or log backup fails after upgrade

Issue

The DB2 log archival fails when you upgrade Commvault version on UNIX platforms:

The GUI log backups might fail post upgrade with an error that says no logs found to backup.

Resolution

  1. After the upgrade is complete, restart the DB2 database Log Manager using the following command for all instances and databases:

    db2pd -db <database_name> -fvp lam1

    For more information, go to article 1140214 on the IBM Support portal.

  2. On AIX computer, after upgrade, run the slibclean command.

DB20002: DB2 online backup fails with SQL2428N error after upgrading Commvault

Issue

The DB2 online backup fails.

Symptom

The following error message is received when an online backup is performed.

SQL2428N The BACKUP did not complete because one or more of the requested log files could not be retrieved

Resolution

The DB2 Services need to be restarted to clear the API information cached by the db2logmgr process. After the restart, retry the backup.

DB20013: After uninstalling the DB2 iDataAgent by using the Control Panel, there are issues connecting to the production database

Cause

The DB2 LOGARCHMETH1 parameter is still associated with the uninstalled Commvault software.

Resolution

Type the following command to clear the LOGARCHMETH1 parameter. This clears the association with the Commvault software.

update database configuration for <database_name> using LOGARCHMETH1 "OFF"

Configuration

DB20003: DB2 instance discovery from the CommCell Console fails

Issue

There may be an error message when you try to discover DB2 instances.

Symptom

You may receive the following error message while trying to discover DB2 instances from the CommCell Console:

Unable to execute SrvDb2Agent to populate CV tables for DB2

Resolution

Restart the services and then try to discover the DB2 instance from the CommCell Console. You cannot discover DB2 Instances from the CommCell Console when the DB2 services are down on the DB2 client computer.

DB20004: DB2 instance discovery fails because the binary is not found

Issue

Sometimes, the DB2 instance can not be discovered from the CommCell Console if the DB2 instance could not find the db2ls binary file location.

Symptom

The Auto-discover instance depends on the db2ls binary file. It fails when the binary can not be located.

Resolution

The db2ls binary file location is a user defined path. Generally, the path to this file is /usr/local/bin.

Verify the path to the db2ls binary file is specified in the .profile of root user. If the path is not specified, add the following in the .profile of the root user:

export PATH=$PATH:/usr/local/bin

Restart the Commvault services from the same terminal session.

DB20005: DB2 instance discovery fails because of incorrect credentials

Issue

DB2 databases are not discovered from the CommCell Console.

Symptom

DB2 databases are not discovered from the CommCell Console because the database credentials are incorrect.

Resolution

Enter the correct user account credentials for the DB2 instance.

DB20014: DB2 dir_cache parameter can cause the database access processes to hang

Issue

If you use DB2 V9.7fp10 and the directory cache (dir_cache) parameter is set to yes, which is the default, processes that access the database (for example create db, list db) can hang. The processes are waiting for the sqleDirCacheLatch latch.

The stack trace shows most of the agents are waiting for the SQLO_LT_SQLE_KRCB__sqleDirCacheLatch latch.

Resolution

Set DIR_CACHE to no ("DIR_CACHE=NO").

DB20015: DB2 Backup Set Log Storage Policy is not automatically updated when you reassign the storage policy at the storage policy level

Issue

The Log Storage Policy configured for a DB2 backup set (Backup Set Properties dialog box, General Tab, Storage Policy for All Log files list) is not updated if you reassign the policy at the storage policy level (Storage Policy Properties dialog box, Associated Subclients tab,

Resolution

Manually reassign the policy to the backup set.

Note: You must do this for each backup set that has a reassigned storage policy.

  1. From the CommCell Browser, navigate to Client Computers > client > DB2> instance.

  2. Right-click the backupset and click Properties.

    The Backup Set Properties dialog box appears.

  3. On the General tab, select the new storage policy from the Storage Policy for All Log files list.

  4. Click OK.

DB20016: The connection to a DB2 Database Does Not Work and the CommCell Console Backup Fails

Issue

The connection to the DB2 database does not work, and the CommCell Console backup fails with the following error:

An error occurred while accessing the shared library "C:\PROGRAM FILES\COMMVAULT\CONTENTSTORE\BASE\DB2SBt.dll"

Resolution

Verify the following configuration items:

  • The env PATH variable is set

  • The DB2 LOGARCHMETH1 parameter is set to C:\commvault\contentstore\base\db2sbt.dll

  • The db2vars.env file is located under the db2_home\sqllib\cfg folder

    If the file exists, then you must set the Commvault base directory as part of the path.

    Example

    PATH=E:\Commvault\ContentStore\Base;C:\ProgramData\Oracle\Java\javapath;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT% \System32\WindowsPowerShell\v1.0\;C:\Program Files\ibm\gsk8\lib64;C:\Program Files (x86)\ibm\gsk8\lib;D:\DB2V10.5\IBM\BIN;D:\DB2V10.5\IBM \FUNCTION;D:\DB2V10.5\IBM\SAMPLES\REPL INCLUDE=D:\DB2V10.5\IBM\INCLUDE;D:\DB2V10.5\IBM\LIB LIB=;D:\DB2V10.5\IBM\LIB CLASSPATH=.;D:\DB2V10.5\IBM\java\db2java.zip;D:\DB2V10.5\IBM\java\db2jcc.jar;D:\DB2V10.5\IBM\java\sqlj.zip;D:\DB2V10.5\IBM\java \db2jcc_license_cu.jar;D:\DB2V10.5\IBM\bin;D:\DB2V10.5\IBM\java\common.jar 
     LOCPATH=

Loading...