Symptom
The restore operation fails when you are restoring files or folders from a snapshot.
Cause
The restore fails if the Hyper-V role is not enabled in the MediaAgent computer.
Resolution
In this scenario, you can use following procedure to restore files and folders from a disk level backup:
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Enable Hyper-V role on the MediaAgent computer and perform the restore operation.
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Using advanced browse option, select another MediaAgent computer with Hyper-V role enabled on it. It could possibly be the computer where the snap backups were performed or the destination computer specified during the restore where the MediaAgent is available with the Hyper-V role enabled.