System Requirements for Protecting VMware VMs with Commvault

Verify that your environment meets the requirements for protecting VMware VMs with Commvault.

Access Nodes

Windows

  • Microsoft Windows Server 2022 x64 Editions (Standard, DataCenter, and Core)

  • Microsoft Windows Server 2019 (Standard, Datacenter) (64-bit only) x64 Editions (Standard, DataCenter, and Core)

  • Microsoft Windows Server 2016 x64 Editions (Standard, DataCenter, and Core)

  • Microsoft Windows Server 2012 R2 x64 Editions (Standard, DataCenter, and Core)

  • Microsoft Windows Server 2012 x64 Editions (Standard, DataCenter, and Core)

Linux

For Linux access nodes, use one of the following options:

  • Deploy a File Recovery Enabler for Linux (FREL) to serve as an access node. For more information, see Linux Proxy Support for the VSA with VMware.

  • Install the Virtual Server Agent on a Linux machine that runs any of the following operating systems:

    • CentOS version 7.4, 7.5, 7.6, 7.7, 7.8, or 7.9

    • Oracle Linux version 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8, or 9.x

    • RHEL 7.4, 7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, 8.7, 8.8, or 9.x

    Note

    • To use a machine that runs RHEL 7.7 as a VSA proxy, you must install the pcre-devel-8.32-17.el7.x86_64 package.

    • For Oracle Linux 8.x or 9.x or RHEL 8.x or 9.x VMs, to install operating system packages that are required to enable automatic installation of Mono, register the VMs with Oracle Linux or Red Hat.

For more information, see Deploying a Linux Machine as a VSA Proxy.

Support for Linux access nodes for VMware is enabled by default for the HyperScale 1.5 Appliance and HyperScale X Appliance. You can select appliance nodes to act as Linux access nodes.

Hard Drive

Verify that at least 100 GB free space is available for installing the Virtual Server Agent.

VMware vCenter Server

The following versions are supported for vSphere, vCenter, vCenter Server Appliance, and ESX/ESXi:

4.1 or later, 5.0.x, 5.1.x, 5.5, 5.5.1, 5.5.2, 5.5.3, 5.5.6, 6.0, 6.0.1, 6.0.2, 6.0.3, 6.5, 6.7, 6.7.1, 6.7.2, 6.7.3, 7.0, 7.0.1, 7.0.2, 7.0.3, 8.0, 8.0.1, 8.0.2

For any ESXi servers, the VADP is not available in the free version of ESXi. The Essentials licensing level or higher is required.

VMware Cloud Director

VMware Cloud Director 5.1.x, 5.5.x, 8.0, 8.1, 8.2, 9.0, 9.1, 9.5, 9.7, 10.0, 10.2, 10.3, 10.4

Guest VM Requirements

Component

Requirements

VM hardware version

4.0, 7.0, 8.0, 9.0, 10.0, 11.0, 13.0, 14.0, 15.0, 17.0, 18.0, 19.0, 20.0, 21.0

VM operating system

All Guest Operating Systems supported by VADP

VMware Tools on VMs

Install the latest version of VMware Tools supported by the host on each VM. At a minimum, the version of VMware tools on VMs must also be supported on the host; unsupported versions must be upgraded.

VMware Transport Considerations

Licensing

In vSphere 5.0, the SCSI HotAdd feature is enabled only for vSphere editions Enterprise and higher, which have Hot Add licensing enabled. No separate Hot Add license is available for purchase as an add-on. In vSphere 4.1, Hot Add was also enabled in the Advanced edition. Customers with vSphere Essentials or Standard editions are not able to perform proxy-based backup, which relies on SCSI HotAdd. Those customers must use alternate transport modes.

SCSI Controllers

HotAdd relies on the SCSI protocol. With VDDK 6.5 or later, VMware recommends the paravirtual SCSI (PVSCSI) controller. (For more information, see Virtual Disk Development Kit Release Notes.) For older VDDK versions, use the LSI SCSI controller. HotAdd does not support IDE disks.

For more information, see System Requirements for Virtual Server Agent with VMware.

Loading...