Azure: System Requirements

For Azure, you can install the VSA on one or more virtual machines or Azure virtual machines. Any virtual machine that has the VSA installed can function as a VSA proxy to perform backups and restores.

For best results, deploy the VSA proxy on a virtual machine in the Azure cloud. Deploying the VSA proxy on an Azure VM that is compute optimized supports faster backups. If the Azure subscription includes multiple regions, deploy at least one VSA proxy in each region.

The VSA proxy machine must run one of the following operating systems:

  • Windows:

    Configure one of the following versions with the required software:

    • Microsoft Windows Server 2022 Editions

    • Microsoft Windows Server 2019 Editions

    • Microsoft Windows Server 2016 Editions

    • Microsoft Windows Server 2012 R2 Editions

  • Linux:

    Install the Virtual Server Agent on a Linux machine that runs any of the following operating systems:

    • CentOS 7.4, 7.5, 7.6, 7.7, 7.8, or 7.9

    • Oracle Linux 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, or 8.7

    • RHEL 7.4, 7.5, 7.6, 7.7, 7.8, 7.9, 8.0, 8.1, 8.2, 8.3, 8.4, 8.5, 8.6, or 8.7

      Note

      To use a machine that runs RHEL 7.7 as a VSA proxy, you must install the pcre-devel-8.32-17.el7.x86_64 package.

      For Oracle Linux 8 or RHEL 8 VMs, to install operating system packages that are required to enable automatic installation of Mono, register the VMs with Oracle Linux or Red Hat. For more information, see Deploying a Linux Machine as a VSA Proxy.

For more information, see System Requirements for Virtual Server Agent with Azure.

Loading...