Red Hat OpenShift: System Requirements

Deprecated

The OpenShift feature is deprecated. For similar functionality, use Kubernetes.

For comprehensive information about deprecated features, see End-of-Life, Deprecated and Extended Support - Features.

You can use the Virtualization solution in the Command Center to back up and restore applications that run in the Red Hat OpenShift Container Platform.

OpenShift Version

This solution requires Red Hat OpenShift Container Platform 3.9, 3.10, or 3.11.

Note

Red Hat OpenShift Container Platform versions 4.2, 4.3, 4.4, and 4.5 are supported by the Kubernetes solution only.

Container Storage

This solution requires Red Hat Gluster Storage in converged or independent mode.

VSA Access Node (Proxy)

You can deploy the Virtual Server Agent on a physical or virtual machine that meets the following requirements:

  • Deployed in the OpenShift environment or externally.

  • Runs one of the following Linux operating systems:

    • Red Hat Linux 7.x or 8

    • CentOS 7.x or 8

      Note

      For Oracle Linux 8 or RHEL 8 VMs, to install operating system packages that are required to enable automatic installation of Mono, register the VMs with Oracle Linux or Red Hat.

  • Has network access to the OpenShift master node.

  • Has SSH access to each GlusterFS endpoint.

  • Has glusterfs and gluster-fuse packages installed.

Proxy Installation Requirements

Loading...