Loading...

MediaAgent - System Requirements

The following requirements are for the MediaAgent:

Best Practice

Important: Use the most recent version of the operating system that is listed. The Commvault software fully supports the most recent version of an operating system, until the vendor ends support. More recent versions of the Commvault software might not install on operating systems that are not supported by the vendor anymore. For information about the support lifecycle of an operating system, contact the vendor.

Operating Systems

Operating System

Operating System Version

Architecture

AIX

 

AIX 7.2 64-bit

PowerPC (including IBM System p)

 

AIX 7.1 64-bit

PowerPC (including IBM System p)

 

AIX 6.1 64-bit

PowerPC (including IBM System p)

HP-UX

HP-UX 11i v3 (11.31) 64-bit

Itanium

 

HP-UX 11i v2 (11.23) 64-bit

Itanium

Linux

 

Amazon Linux

 

 

Amazon Linux AMI 2017.03

  • x86
  • x64
  • Compatible processors

 

 

Amazon Linux release 2 (Karoo)

  • x86
  • x64
  • ARM64
  • Compatible processors

 

 

OpenSuSE

 

 

OpenSuSE 13.2 with glibc 2.19*

x64

 

Oracle Linux

 

 

Oracle Linux 7.x with glibc 2.17.x

  • x86
  • x64
  • Compatible processors

     

 

Oracle Linux 6.x with glibc 2.12.x

  • x86
  • x64
  • Compatible processors

     

 

Oracle Linux 5.x with glibc 2.5.x

  • Intel Pentium
  • x64
  • Compatible processors

     

 

Red Hat Enterprise Linux AS/ES

 

 

Red Hat Enterprise Linux/CentOS 8.x with glibc 2.17.x

x64

 

Red Hat Enterprise Linux AS 5.x with glibc 2.5

x64

 

Red Hat Enterprise Linux/CentOS

 

 

Red Hat Enterprise Linux/CentOS 5.x with glibc 2.5.x

PowerPC (including IBM System p)

 

Red Hat Enterprise Linux/CentOS 7.x with glibc 2.17.x

  • x86
  • x64
  • PowerPC
  • ARM64
  • Compatible processors

     

 

Red Hat Enterprise Linux/CentOS 6.x with glibc 2.12.x

  • Intel Pentium
  • PowerPC (Includes IBM System p)
  • Compatible processors

     

 

Red Hat Enterprise Linux/CentOS 6.x with a minimum of glibc 2.12-1.25.x

x64

 

Red Hat Enterprise Linux/CentOS 5.x with glibc 2.5.x

  • Intel Pentium
  • x64
  • PowerPC (Includes IBM System p)
  • Compatible processors

     

 

Red Hat Enterprise Linux/CentOS 5 Advanced Platform with glibc 2.5.x

Intel Pentium or compatible 650 MHz processor minimum recommended; Dual 1 GHz or higher processors recommended

 

Red Hat Enterprise Linux/CentOS 5 Advanced Platform with glibc 2.5.x

x64

 

SuSE Linux 12 (Initial Release/SP1/SP2/SP3/SP4/SP5) with glibc 3.x

** Deduplication stores are not supported on Power PC (Little endian).

  • x86
  • x64
  • PowerPC
  • Compatible processors

     

 

SuSE Linux 12 (Initial Release/SP1/SP2/SP3/SP4/SP5) with glibc 2.x

** Deduplication stores are not supported on Power PC (Little endian).

  • x86
  • x64
  • PowerPC
  • Compatible processors

     

 

SuSE Linux 11 (Initial Release/SP1/SP2/SP3/SP4) with glibc 3.x

  • x86
  • x64
  • PowerPC
  • Compatible processors

     

 

SuSE Linux 11 (Initial Release/SP1 and later SPs) with glibc 2.9.x and higher

  • x86
  • x64
  • PowerPC
  • Compatible processors

     

 

SuSE Linux 11(Initial Release/SP1/SP2/SP3/SP4) with glibc 2.11.x

Intel Pentium, x64 or compatible processors

 

SuSE Linux 10 Enterprise Server Edition with glibc 2.6.x

  • x86
  • x64
  • PowerPC
  • Compatible processors

     

 

Ubuntu

 

 

Ubuntu 19.04

  • x86
  • x64
  • ARM64
  • Compatible processors

     

 

Ubuntu 18.04 LTS

  • x86
  • x64
  • ARM64
  • Compatible processors

     

 

Ubuntu 16.04 LTS

  • AMD64
  • Intel 64
  • Compatible processors

     

 

Ubuntu 14.04 LTS

  • Intel Pentium
  • Itanium
  • x64
  • Compatible processors

     

 

Ubuntu 12.04 LTS

  • x86
  • x64
  • Compatible processors

     

Solaris

Solaris 11.x

Ultra5 station or more recent

Dual processors recommended.

 

Solaris 11.x

x64

 

Solaris 10 Update 6 or equivalent*

*sol-10-encrypt-GA-iso.zip package is required on Solaris 10.

x64

 

Solaris 10 Update 6 or equivalent*

*sol-10-encrypt-GA-iso.zip package is required on Solaris 10.

UltraSPARC-II or more recent recommended; Dual Processors recommended

Windows

Windows Server 2019

 

 

Microsoft Windows Server 2019 Editions

All Windows-compatible processors are supported

 

Microsoft Windows Server 2019 Core Editions

 

 

Windows 2012

 

 

Microsoft Windows Server 2012 R2 Editions

See Considerations for Microsoft Windows Server 2012, 2012 R2, and Windows 8 for more information.

 

 

Microsoft Windows Server 2012 Editions

For more information, see Considerations for Microsoft Windows Server 2012, 2012 R2, and Windows 8.x.

All Windows-compatible processors are supported

 

 

Microsoft Windows 10

 

 

Microsoft Windows Client 10 Editions*

Tape Libraries/Drives are not supported.

All Windows-compatible processors are supported

 

Windows 2016

 

 

Microsoft Windows Server 2016 Editions

For more information, see Considerations for Microsoft Windows Server 2016.

All Windows-compatible processors are supported

AIX LPAR Support

Data protection on Logical Partitioning (LPAR) is supported.

Hardware Specifications

General guidelines on the hardware required for MediaAgents installed either on physical or virtual machines is explained in Deduplication Mode

Notes:

  • Software installation requires 20 GB of disk space on the operating system drive. This space is used for temporary files copied during the installation or upgrade of the MediaAgent software.
  • 10 GB is required for MediaAgent software and log file growth.
  • Optimal performance will be realized with solid-state drive (SSD) technology for your local index cache disk. This is particularly important in cases of:
    • NAS filers running NDMP backups
    • Backing up large file servers
    • Any situation where performance is critical

    Hardware requirements for index cache is explained in Indexing: Planning

  • Recommended hardware requirements for MediaAgents is explained in the following pages, based on the deduplication mode required for your environment.

Miscellaneous

During the installation of this software component, the File System Agent is installed if it is not already installed. See the system requirements for the Microsoft Windows File System Agent.

Microsoft Visual C++ Redistributable 2017 is Automatically Installed

Starting in Service Pack 18, Microsoft Visual C++ Redistributable 2017 (vcredist2017.exe) is automatically installed. If a computer does not have the latest Windows updates, the installation of Microsoft Visual C++ Redistributable 2017 will fail in installing Universal C Runtime.

The following Windows updates must be installed to prevent the installation failure:

KB2919355

KB2939087

KB2975061

KB2999226

Updates are not required on latest Windows operating system versions, such as Microsoft Windows 10 and Microsoft Windows Server 2016, as these versions come with the Universal C Runtime already installed.

Cloud Server Support

The MediaAgent can be installed on a Virtual Server in a Cloud. For example, Virtual Server in Amazon EC2.

After the installation, make sure that the remote clients can access this MediaAgent.

.NET Framework

.NET Framework 4.5 is automatically installed. Note that .NET Framework 4.5 can co-exist with other versions of this software.

Hardware Compatibility List

For information on Tape Hardware/Driver support, see Hardware Matrix.

DISCLAIMER

Third-party maintenance (minor) releases or feature releases that are supported by the Commvault software may not be listed in our System Requirements. When possible, Commvault provides information on any known issues related to these minor releases or feature releases. In some cases, these minor releases or feature releases affect how the Commvault software works. Commvault software may experience changes in functionality as the result of the third-party minor release or feature releases. These changes are beyond the control of Commvault. Platforms that are supported in the current version of Commvault software may not be supported in earlier versions of the software. Contact your software provider to ensure that third-party minor releases or feature releases are compatible with the Commvault software.

Additional considerations regarding minimum requirements and End-of-Life policies from third-party vendors also apply.

Last modified: 4/3/2020 1:50:31 PM