Loading...

Web Console and Command Center: System Requirements

The following requirements are for Web Console and Command Center. (The Web Console is installed as part of the Command Center package.)

Best Practice

Use the latest version of the operating system software listed in the Operating System table. Commvault software fully supports the latest version of an operating system until the vendor ends support. Newer versions of Commvault software might not install on operating systems for which vendor support has ended. For information about the Microsoft support lifecycle, go to the Microsoft Support website, Microsoft Support Lifecycle. For support lifecycle information for other operating systems, contact the appropriate software vendor.

Operating System

Operating System

Operating System Version

Architecture

Linux

Red Hat Enterprise Linux/CentOS

 

 

Red Hat Enterprise Linux/CentOS 7.x with glibc 2.17.x

x86, x64, Power PC or compatible processors

Windows

Windows Server 2019

 

 

Microsoft Windows Server 2019 Editions

All Windows-compatible processors supported

 

Windows Server 2016

 

 

Microsoft Windows Server 2016 Editions

All Windows-compatible processors supported

 

Windows 2012

 

 

Microsoft Windows Server 2012 Editions

All Windows-compatible processors supported

 

Microsoft Windows Server 2012 R2 Editions

All Windows-compatible processors supported

Hard Drive

  • Web Console: 2 GB of local disk space for the software and log file growth.
  • Command Center: 500 GB of local disk space recommended
  • 1 GB of temp space on the drive on where the temp folder resides.

Hardware Specifications

The hardware requirements for the Web Console on either physical or virtual machines is explained in the Architecture Planning Guide.

Supported Web Browsers

  • Apple Safari version 8.0 and later
  • Google Chrome version 40.0 and later
  • Microsoft Edge
  • Microsoft Internet Explorer (IE) version 11
  • Mozilla Firefox version 47.0 and later

Cluster Support

The software is supported on a cluster only when installed on a Cluster with CommServe software. For more information on supported cluster types, see Clustering - Support.

Miscellaneous

Internet Information Services (IIS)

Internet Information Services (IIS) must be enabled on the computer on which you plan to install the Command Center.

Apache Tomcat Server

The Apache Tomcat Server is automatically installed during installation of this software if it is not already installed.

Note: Manually upgrading the Apache Tomcat Server is not supported. We always update the Tomcat server with the latest security updates, so that the components using the Tomcat server are free from any vulnerabilities reported by the open source community.

Java SE Platform

The software supports Java 11.

The Java version is installed automatically during the installation of this software. If you already have a system installed Java version, the software will install another instance of the supported Java version in the software installation path.

Note: Manually upgrading the Java version installed by the software is not supported. We always update the Java version with the latest security updates, so that the components using Java are free from any vulnerabilities reported by the open source community.

File System Agent

The File System Agent is installed automatically during the installation of this software component (if it is not installed already). To review the system requirements of the File System Agent, see System Requirements - Microsoft Windows File System Agent.

Note: For successful web restore of NAS data and Domino emails, install a 32-bit File System proxy instance on a 64-bit machine.

DISCLAIMER

Third-party maintenance (minor) releases or service packs that are supported by the Commvault software may not be listed in our System Requirements. When possible, Commvault provides information on any known issues related to these minor releases or service packs. In some cases, these minor releases or service packs affect how the Commvault software works. Commvault software may experience changes in functionality as the result of the third-party minor release or service pack. These changes are beyond the control of Commvault. Platforms that are supported in the current version of Commvault software may not be supported in earlier versions of the software. Contact your software provider to ensure that third-party minor releases or service packs are compatible with the Commvault software.

Additional considerations regarding minimum requirements and End-of-Life policies from third-party vendors also apply.All Windows-compatible processors supported

Last modified: 3/28/2019 7:08:09 PM