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VOVM0001: VSA proxy fails to validate connection to Oracle VM Manager 3.3 with "SSL connect error"

When discovering virtual machines with Oracle VM Manager, the Virtual Server Agent proxy fails to validate the connection to Oracle VM Manager because of an SSL connect error.

This error can occur with Oracle VM Version 3.3.1 through 3.3.3.

Symptom

The following error message occurs in the cvd.log file on the VSA proxy:

CVLibCurl::CVLibCurlSendHttpReqLog() - curl-err:[SSL connect error]

Cause

A known issue with Oracle VM Manager 3.3 can cause an SSL connect error.

Resolution

In Doc ID 2099148.1, Oracle recommends the following workaround for Oracle VM Manager 3.3.3:

  1. Make a backup copy of the configuration file on the WebLogic server:

    # cd /u01/app/oracle/ovm-manager-3/domains/ovm_domain/config
    # cp config.xml config.xml.bak

  2. Edit the config.xml file and add the following line:

    <ciphersuite>TLS_RSA_WITH_AES_128_CBC_SHA</ciphersuite>

    The resulting file should be similar to the following example:

    <ssl>
    <name>AdminServer</name>
    <enabled>true</enabled>
    <ciphersuite>TLS_RSA_WITH_RC4_128_SHA</ciphersuite>
    <ciphersuite>TLS_RSA_WITH_RC4_128_MD5</ciphersuite>
    <ciphersuite>TLS_RSA_WITH_AES_128_CBC_SHA</ciphersuite>
    <hostname-verifier>weblogic.security.utils.SSLWLSWildcardHostnameVerifier</hostname-verifier>

  3. Restart the ovmm service:

    # service ovmm restart

Last modified: 4/27/2018 7:50:03 PM