Loading...

Private Metrics Reporting Server: System Requirements

The following requirements are for the Private Reporting Server package.

Operating System

Important: Use the most recent version of the operating system that is listed. The Commvault software fully supports the most recent version of an operating system, until the vendor ends support. More recent versions of the Commvault software might not install on operating systems that are not supported by the vendor anymore. For information about the support lifecycle of an operating system, contact the vendor.

  • Microsoft Windows Server 2019 Editions
  • Microsoft Windows Server 2019 Core Editions

    Microsoft Windows Server 2016 Editions

  • Nano Servers are not supported. For more information, see Considerations for Microsoft Windows Server 2016.
  • Microsoft Windows Server 2012 Editions

    Microsoft Windows Server 2012 R2 Editions

  • Server Core installations are not supported.

Hard Drive

The hardware requirements for a Private Metrics Reporting Server installed on either physical or virtual machines are explained in Hardware Specifications for the Private Metrics Reporting Server.

Database Engine

Microsoft SQL Server 2016 Standard Edition is automatically installed during the installation of the Metrics Reporting Server software. If you have Microsoft SQL Server 2012 Enterprise Edition already installed in your environment, the Metrics Reporting Server will use the existing SQL Server.

For more information, see Database Engine under System Requirements - CommServe.

Supported Web Browsers

  • Apple Safari (versions that are not older than a year)
  • Google Chrome (versions that are not older than a year)
  • Mozilla Firefox (versions that are not older than a year)
  • Microsoft Edge
  • Microsoft Internet Explorer version 11

Miscellaneous

Apache Tomcat Server

The Apache Tomcat Server is automatically installed during installation of this software if it is not already installed.

Note: Manually upgrading the Apache Tomcat Server is not supported. We always update the Tomcat server with the latest security updates, so that the components using the Tomcat server are free from any vulnerabilities reported by the open source community.

Internet Information Services (IIS)

By default, the Web Server and Web Console packages are installed with the CommServe. To install this software, IIS must be enabled on the CommServe computer and meet the following requirements:

  • Microsoft Internet Information Services (IIS) Manager version 10.0 (on Windows 2016 only)
  • Microsoft Internet Information Services (IIS) Manager version 8.0 or 8.5 (on Windows 2012 only)
  • Microsoft Internet Information Services (IIS) Manager version 7.5

.NET Framework

The Microsoft .NET Framework 4.6 is required and is automatically installed.

DISCLAIMER

Third-party maintenance (minor) releases or feature releases that are supported by the Commvault software may not be listed in our System Requirements. When possible, Commvault provides information on any known issues related to these minor releases or feature releases. In some cases, these minor releases or feature releases affect how the Commvault software works. Commvault software may experience changes in functionality as the result of the third-party minor release or feature releases. These changes are beyond the control of Commvault. Platforms that are supported in the current version of Commvault software may not be supported in earlier versions of the software. Contact your software provider to ensure that third-party minor releases or feature releases are compatible with the Commvault software.

Additional considerations regarding minimum requirements and End-of-Life policies from third-party vendors also apply.

Last modified: 5/25/2021 2:52:59 PM