Symptom
Application-aware backups performed using the Virtual Server Agent (VSA) fail with a message indicating the Hardware Snapshot Enabler license is not available.
The license.log file can include the following error messages:
9396 159c 06/13 13:55:19 ### No permanent license is available for license type [163].
9396 159c 06/13 13:55:19 ### License - Type [163] Name [Hardware Snapshot Enabler]: No permanent license available. Will check if free eval licenses are present
9396 159c 06/13 13:55:19 ### Number of used license [7] is equal to number of licenses issued [7]. So no free eval licenses available for license type [163]
9396 159c 06/13 13:55:19 ### License - Type [163] Name [Hardware Snapshot Enabler]: No free license is available.
9396 159c 06/13 13:55:19 ### [7] eval license [Hardware Snapshot Enabler (163)] are issued
The following error messages might be listed instead:
Failed to consume the license [163] for apptype [1092]. Error [ This license [Hardware Snapshot Enabler] is not available at this time.]
Arguments passed are: clientid [1016], apptype [1092], licType [163], bConfigure [1]: 67109161
LibConfigAppClientProp::setGeneralProperties() - Failed to allocate License for Snap Backup.Please check if License is not available
Cause
In situations where Commvault software packages were obtained through a reseller, the default OEM license package might not include the Hardware Snapshot Enabler license, which is required for VSA application-aware backups.
Resolution
To resolve this issue, update the identifier for the OEM in the database:
-
Run the following query with the Commvault OEM identifier as input:
qoperation execscript -sn UpdateOEM -si oem_id
For example:
qoperation execscript -sn UpdateOEM -si 115
-
Retry application-aware backup jobs.
For more information, see UpdateOEM.