System Requirements for MySQL in a Kubernetes Cluster

Updated

Verify that your environment meets the system requirements for MySQL in a Kubernetes cluster.

Kubernetes

You can use Kubernetes 1.16 and more recent versions.

MySQL

You can use any version of MySQL that is supported on Linux. For information about supported MySQL versions, see MySQL Agent: System Requirements.

To restore databases that were backed up using XtraBackup utility, the staging location in the MySQL pod must have free space with size equal to the largest database on the MySQL server.

Base Image for Commvault Container

You must use CentOS 7.8.

Persistent Volume for Commvault Container

Each pod must have 3 GB.