Microsoft SQL Server Agent: System Requirements

Updated

Verify that your environment meets the system requirements for for SQL Server.

Application

  • Microsoft SQL Server 2019 Editions up to the latest Service Pack

  • Microsoft SQL Server 2017 Editions up to the latest Service Pack

  • Microsoft SQL Server 2016 Editions up to the latest Service Pack

  • Microsoft SQL Server 2014 Editions up to the latest Service Pack

  • Microsoft SQL Server 2012 Editions up to the latest Service Pack

  • Microsoft SQL Server 2008 R2 Editions up to the latest Service Pack

  • Microsoft SQL Server 2005 Editions up to the latest Service Pack [Extended Support]

Operating System

Important: Use the most recent version of the operating system that is listed. The Commvault software fully supports the most recent version of an operating system, until the vendor ends support. More recent versions of the Commvault software might not install on operating systems that are not supported by the vendor anymore. For information about the support lifecycle of an operating system, contact the vendor.

Linux

For information about SQL Server on Linux, see Microsoft guidelines for SQL Server on Linux on the Microsoft website.

Important: The following operating systems are supported only for the following versions of Microsoft SQL Server. Microsoft has a known issue on Microsoft SQL server 2017 cumulative updates 19 and 20.

  • Microsoft SQL Server 2017 cumulative update 18 or lower

  • Microsoft SQL Server 2017 cumulative update 21 and higher

  • Microsoft SQL Server 2019 cumulative update 5 and higher

Operating system

File system type

Ubuntu 16.04 LTS, 18.04 LTS, and 20.04 LTS (SQL Server 2019 only)

EXT4

SUSE Enterprise Linux Server v12 SP3 - SP5

EXT4

Red Hat Enterprise Linux 7.7 - 7.9, or 8.0 - 8.3 Server

  • EXT4

  • XFS

Windows

Operating system

Processor architecture

Microsoft Windows Server 2022 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2019 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2016 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2012 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2012 R2 Editions

All Windows-compatible processors are supported

Microsoft Windows 10

All Windows-compatible processors are supported

Microsoft Windows 7 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2008 R2 Editions

All Windows-compatible processors are supported

Hard Drive

Component

Space required

Software

256 MB

Log file growth

50 MB

Temporary space for installs or upgrades (where the temp folder resides)

724 MB

Memory (RAM)

2 GB or more

Clustering

If clustering is supported by the operating system, you can install the software on a cluster. For information about supported cluster types, see Support for Cluster Configuration.

On Linux, Install Microsoft ODBC Driver 17.x or a More Recent Version

Install ODBC driver 'Microsoft ODBC 17.x' or above on the SQL server Linux client that you want to back up.

Software That Is Automatically Installed

Microsoft Visual C++ Redistributable 2017

Starting with Service Pack 18, Microsoft Visual C++ Redistributable 2017 (vcredist2017.exe) is automatically installed.

If a computer does not have the most recent Windows updates, the installation of Microsoft Visual C++ Redistributable 2017 will fail in installing Universal C Runtime. The following Windows updates must be installed to prevent the installation failure. The updates are not required on the most recent Windows operating system versions, such as Microsoft Windows 10 and Microsoft Windows Server 2016, because these versions have the Universal C Runtime already installed.

  • KB2919355

  • KB2939087

  • KB2975061

  • KB2999226

.NET Framework

On most versions of Windows, the .NET Framework 4.6.2 is automatically installed.

Java SE Platform

The Java version is installed automatically during the installation of this software. If you already have a system installed Java version, the software will install another instance of the supported Java version in the software installation path.

Manually upgrading the Java version installed by the software is not supported.

DISCLAIMER

Certain third-party software and service releases (together, "Releases") may not be supported by Commvault. You are solely responsible for ensuring Commvault’s products and services are compatible with any such Releases.