PostgreSQL Agent: System Requirements

Updated

Verify that your environment meets the system requirements for PostgreSQL.

Application

  • PostgreSQL and EnterpriseDB Version 9.2–14.x

Operating System

AIX

Operating system

Processor architecture

AIX 7.1 64-bit

PowerPC

FreeBSD

Operating system

Processor architecture

FreeBSD 10.x

  • x64

  • Compatible processors

FreeBSD 9.x

Supported for PostgreSQL Version 9.2 only.

  • x64

  • Compatible processors

Linux

Operating system

Processor architecture

Debian 9.x

  • x64

  • Compatible processors

Debian 8.x

  • x64

  • Compatible processors

Debian 7.x

  • x64

  • Compatible processors

Debian 6.x

  • x64

  • Compatible processors

Debian 5.x

  • x64

  • Compatible processors

Red Hat Enterprise Linux/CentOS 8.x with glibc 2.28.x

Before you install the Commvault software, you must manually install the libxcrypt.x86_64 and libnsl.x86_64 packages on the computer.

  • x64

  • PowerPC (little endian)

  • Compatible processors

Red Hat Enterprise Linux/Oracle Linux Enterprise/CentOS 7.x

  • x64

  • PowerPC (little endian)

  • Compatible processors

Red Hat Enterprise Linux/Oracle Linux Enterprise/CentOS 6.x with glibc 2.12.x

  • Intel Pentium

  • x64

  • Power PC (Little endian)

  • Compatible processors

Red Hat Enterprise Linux/Oracle Linux Enterprise/CentOS 5.x with glibc 2.5.x

  • Intel Pentium

  • x64

  • Compatible processors

Source Mage Linux

x64

SuSE Linux 12 Initial Release

  • x64

  • PowerPC (little endian)

  • Compatible processors

SuSE Linux 11 (Initial Release/SP1 and later SPs) with glibc 2.9.x and higher

  • Intel Pentium

  • x64

  • Power PC (Little endian)

  • Compatible processors

Ubuntu 20.04 LTS

  • Intel Pentium

  • x64

  • Compatible processors

Ubuntu 18.04 LTS

  • Intel Pentium

  • x64

  • Compatible processors

Ubuntu 16.04 LTS

  • Intel Pentium

  • x64

  • Compatible processors

Ubuntu 14.04 LTS

  • Intel Pentium

  • x64

  • Compatible processors

Ubuntu 12.04 LTS

  • Intel Pentium

  • x64

  • Compatible processors

Solaris

Operating system

Processor architecture

Solaris 11.x

  • x64

  • Sparc T/M series

Solaris 10 Update 6 or equivalent

  • x64

  • Sparc T/M series

Windows

Operating system

Processor architecture

Microsoft Windows Server 2019 Editions

All Windows-compatible processors are supported

Microsoft Windows Server 2016 Editions

Server Core installations are not supported.

All Windows-compatible processors are supported

Microsoft Windows Server 2012 R2 Editions

Server Core installations are not supported.

All Windows-compatible processors are supported

Microsoft Windows Server 2012 Editions

Server Core installations are not supported.

All Windows-compatible processors are supported

Microsoft Windows Server 2008 R2 Editions

Server Core installations are not supported.

All Windows-compatible processors are supported

Microsoft Windows Server 2008 Editions

Server Core installations are not supported.

All Windows-compatible processors are supported

Hard Drive

Component

Space required

Software

1 GB

Job results folder

256 MB

Log folder

256 MB

Memory (RAM)

2 GB or more

Block-Level Backups

  • Block-level backups are supported only on Linux platforms. For supported Linux kernel version details of PostgreSQL block-level backups, see List of Supported Kernel Versions.

  • Block-level backups on Network File System (NFS) are not supported.

Software That Is Automatically Installed

Linux File System Agent

The Linux File System Agent is automatically installed during installation of this software, if it is not already installed. For system requirements and installation information, see Linux File System: System Requirements.

Microsoft Visual C++ Redistributable 2017

Starting with Service Pack 18, Microsoft Visual C++ Redistributable 2017 (vcredist2017.exe) is automatically installed.

If a computer does not have the most recent Windows updates, the installation of Microsoft Visual C++ Redistributable 2017 will fail in installing Universal C Runtime. The following Windows updates must be installed to prevent the installation failure. The updates are not required on the most recent Windows operating system versions, such as Microsoft Windows 10 and Microsoft Windows Server 2016, because these versions have the Universal C Runtime already installed.

  • KB2919355

  • KB2939087

  • KB2975061

  • KB2999226

DISCLAIMER

Certain third-party software and service releases (together, "Releases") may not be supported by Commvault. You are solely responsible for ensuring Commvault’s products and services are compatible with any such Releases.