Oracle Cloud Infrastructure: System Requirements

Updated

The following requirements apply when using the Virtual Server Agent with Oracle Cloud Infrastructure.

Hypervisor

Add a separate hypervisor definition for each Oracle Cloud Infrastructure region.

Note: Note: Oracle Cloud Infrastructure allows the creation of sub-compartments up to six levels deep. Beginning in Feature Release 11.26, you can back up and restore instances that are under those sub-compartments (as well as under the root compartment) for OCI regions.

Proxy Requirements

  • The VSA proxy must be an instance running in Oracle Cloud Infrastructure.

  • Deploy a VSA proxy for each availability domain.

  • The proxy must run one of the following operating systems:

    • Windows Server 2019

    • Windows Server 2016

    • Windows Server 2012 R2

    • For Linux proxy support, deploy a File Recovery Enabler for Linux (FREL) on an instance in Oracle Cloud Infrastructure.

      The Linux instance must have the MediaAgent and Virtual Server Agent packages installed.

  • The iscsiadm (isci-initiator-utils) package must be installed on the proxy.

Note: To back up an Oracle Cloud Infrastructure instance that has storage pool disks, you must use a Linux proxy.

FREL Configuration

To restore files from a Linux instance, deploy a File Recovery Enabler for Linux (FREL). The FREL instance must meet the following requirements:

  • Oracle Linux 8.4

  • Oracle Linux 8.5

  • Virtual Server Agent and MediaAgent packages installed

For more information, see the following pages:

Proxy Installation Requirements

On Windows:

On UNIX:

Guest Operating System Support

The following guest instance operating systems are supported for VM conversion:

  • Oracle Linux 7

  • Oracle Linux 8

  • RHEL 6, RHEL 7

  • Windows Server 2016

  • Windows Server 2012 R2

  • Windows Server 2008 R2